Buy and Resell(HDU6438)

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

 

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

 

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

 

Sample Output

 

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

题意:题意为有一些按顺序给出的村子,在每个村子可以买入或者卖出一件商品,或者什么也不干。每个村子的买入与卖出价格相等,问所能获得的最大利益以及最少交易次数。

思路:用一个优先队列维护一下,如果优先队列的最小值比当前的值小,我们将利益增加,然后向队列里加入两个当前值,加入两个的原因是为了可以反悔,假设后面有两个比它大的值,一个可以与它交易,一个可以理解为与比他小的交易,比如 a<b, b<c,那么(b-a)+(c-b)=(c-a), 这个思路就有点像网络流中求增广路加反向边的操作,为自己留了一次反悔的机会,我们看那个最小值是第几次出现,如果是第一次出现,我们次数不增加,因为第一次可以理解为与比它更小的值交易,如果是第二次,交易次数加二,另外,如果队列里的值没有比当前值小的,需要直接加入队列中,最开始忘了这个,wa了十几发。

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
struct P
{
    int first, second;
    bool operator < (const P& a) const
    {
        if(first == a.first)
        {
            return second < a.second;
        }
        return first > a.first;
    }
    P(int a, int b):first(a), second(b){}
    P(){}
};
priority_queue<P>q;
LL a[maxn];
int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--)
    {
        while(!q.empty()) q.pop();
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%lld", &a[i]);
        }
        q.push(P(a[1], 1));
        LL cnt = 0, ans = 0;
        for(int i = 2; i <= n; i++)
        {
            //cout << ans << " ";
            if(q.empty() || q.top().first >= a[i])
            {
                q.push(P(a[i], 1));
                continue;
            }
            P tmp = q.top();
            q.pop();
            if(a[i] > tmp.first)
            {
                if(tmp.second == 1)
                {
                    cnt += 2;
                    ans += (a[i]-tmp.first);
                    q.push(P(a[i], 2));
                }
                else
                {
                    ans += (a[i]-tmp.first);
                    q.push(P(a[i], 2));
                    q.push(P(tmp.first, 1));
                }
            }
            else
            {
                q.push(P(a[i], 1));
            }
        }
        printf("%lld %lld\n", ans, cnt);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值