Buy and Resell(优先队列)

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3189 Accepted Submission(s): 1194

Problem Description
The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

  1. spend ai dollars to buy a Power Cube
  2. resell a Power Cube and get ai dollars if he has at least one Power Cube
  3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input
There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

Output
For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input
3
4
1 2 10 9
5
9 5 9 10 5
2
2 1

Sample Output
16 4
5 2
0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. profit = 0

题意: 有n个城市,第i天你会达到第i个城市,在第i个城市中,你可以用ai元购买一个物品,或者用ai元卖掉一个物品,你可以同时保存多个物品。最开始你身上没有物品,但是又无限的金钱,现在要求你从城市1走到城市n,问你最大的收益是多少。
解法:因为要求我们赚的最多,因此我们必定是优先将最贵的跟买入最便宜的相减,因此我们可以考虑对价值开一个小根堆进行维护 。而倘若我们发现在第i天中,Ai>之前的最小值,则此时的Ai可能作为中间商,因此我们可以将Ai压入队列两次,代表Ai可能作为中间商影响答案。
至于统计次数cnt,我们发现,倘若Ai是中间商(即Ai在队列内还影响答案了),则我们则不需要统计这一次的记录,否则我们需要将次数cnt+1即可。
Source
2018中国大学生程序设计竞赛 - 网络选拔赛

#include <iostream>
#include <queue>
#include <cstdio>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
priority_queue<int, vector<int>, greater<int> >que;//优先队列
map<int,int>mp;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
    while (!que.empty())
        que.pop();
    mp.clear();
    scanf("%d",&n);
        ll res = 0, cnt = 0;
        for(int i = 1; i <= n; i++)
        {
            int x ;
            scanf("%d",&x);
            if(!que.empty() && que.top() < x)
            {
                int now = que.top();
                que.pop();
                res += x - now;
                que.push(x);
                cnt++;
                if (mp[now])
                {
                    cnt--;
                    mp[now]--;
                }
                mp[x]++;
            }
            que.push(x);
        }
        cout<<res<<" "<<cnt*2<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值