L1-064 估值一亿的AI核心代码 (20分)

在这里插入图片描述
以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know

代码:

这里是引用

import java.util.Scanner;
public class Main{
	public static void main(String [] args) {
		Scanner in=new Scanner(System.in);
		int n,i,j;
		n=Integer.parseInt(in.nextLine());
		String[] strs=new String[n];
		
		for(i=0;i<n;i++) {
			strs[i]=in.nextLine();
            System.out.println(strs[i]);
			strs[i]=strs[i].trim();
			strs[i]=strs[i].replaceAll(" +", " ");//将多个空格变成一个
			strs[i]=strs[i].replaceAll("I","0"); 
			strs[i]=strs[i].replaceAll(" (\\W)","$1");//将标点符号前的空格去掉
			strs[i]=strs[i].toLowerCase();
			strs[i]=strs[i].replaceAll("0", "I");
			strs[i]=strs[i].replaceAll("\\bcan you\\b", "1");//\b匹配单次的边界
			strs[i]=strs[i].replaceAll("\\bcould you\\b", "2");
			strs[i]=strs[i].replaceAll("\\b(I|me)\\b", "3");
			strs[i]=strs[i].replaceAll("1", "I can");
			strs[i]=strs[i].replaceAll("2", "I could");
			strs[i]=strs[i].replaceAll("3", "you");
			strs[i]=strs[i].replaceAll("\\?", "!");
            System.out.println("AI: "+strs[i]);
		}
		
	}
}
        
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值