LightOj-1245

Description

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
        res
 = res + n / i;
   
 return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386



题目大意:用递归的方法去求H(n)太费事了,请找到规律,减少求H(n)的时间

解体思路:以100为例,通过列举几项发现,求H(n),即求有多少个1,多少个2,多少个3,一直到n/2,最后加上n。

设有x个i,则x*i=(n/i-n/(i+1))*i

这将一个大的数折成一半了(循环长度为n/2),然而还是会超时。因此继续优化,

我们可以将循环长度减到sqrt(n);从1-100,100-1同时计算,但会出现重复计算的地方,只要剪去就可以了。

代码如下:

#include<stdio.h>
#include<cmath>
int main()
{
	long long r,t,i,s,sum,j;
	scanf("%lld",&t);
	j=1;
	while(t--)
	{
		scanf("%lld",&r);
		s=sqrt(r);
		sum=0;
		for(i=1;i<s+1;i++)
		{
			sum+=(r/i-r/(i+1))*i+r/i;
			if(r/i==i)//出现重叠的地方 
			sum-=i;
		}
		printf("Case %lld: %lld\n",j++,sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值