LightOJ 1245【数学】


Description

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
        res
 = res + n / i;
   
 return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386


比较容易发现规律,这个跟约数是有关的,比如20 对哪些数除掉之后整数部分是 2 那么从这里开始考虑: 那么小数可能是为0-0.99999....也就是 0 1 之间,那么直接让20 去除这两个端点的极限,得到的数值不就是除过之后整数部分为 2 的数了吗?也就是 20/2=10  20/3=6,也就是从 6的下一位7 到 10,全是商位于2 和 3  之间的数.......

然后这样规律就出来了........


#include<stdio.h>
#include<math.h>
typedef long long ll;
ll num(ll x)
{
	ll sum=0,tp=sqrt(x);
	for(int i=1;i<=tp;++i)
	{
		sum=sum+(x/i-x/(i+1))*i+x/i;//恶心的规律 
	}
	if(tp==x/tp)//恶心的条件
	{
		sum-=tp;
	}
	return sum;
}

int main()
{
	int t;ll x;
	//freopen("shuju.txt","r",stdin);
	scanf("%d",&t);
	for(int k=1;k<=t;++k)
	{
		scanf("%lld",&x);
		printf("Case %d: %lld\n",k,num(x));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值