hdu--2377

                                 Bus Pass

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 843    Accepted Submission(s): 334


Problem Description
You travel a lot by bus and the costs of all the seperate tickets are starting to add up.

Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:



Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!
 

Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers id i (1 <= id i <= 9 999) and mz i (1 <= mz i <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mz i integers: the numbers of the adjacent zones.

nr lines starting with one integer mr i (1 <= mr i <= 20), indicating the number of zones the ith bus trip visits, followed by mr i integers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

 

Output
For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

 

Sample Input
  
  
1 17 2 7400 6 7401 7402 7403 7404 7405 7406 7401 6 7412 7402 7400 7406 7410 7411 7402 5 7412 7403 7400 7401 7411 7403 6 7413 7414 7404 7400 7402 7412 7404 5 7403 7414 7415 7405 7400 7405 6 7404 7415 7407 7408 7406 7400 7406 7 7400 7405 7407 7408 7409 7410 7401 7407 4 7408 7406 7405 7415 7408 4 7409 7406 7405 7407 7409 3 7410 7406 7408 7410 4 7411 7401 7406 7409 7411 5 7416 7412 7402 7401 7410 7412 6 7416 7411 7401 7402 7403 7413 7413 3 7412 7403 7414 7414 3 7413 7403 7404 7415 3 7404 7405 7407 7416 2 7411 7412 5 7409 7408 7407 7405 7415 6 7415 7404 7414 7413 7412 7416
 

Sample Output
  
  
4 7400
 

题目大意:有一个城市中心,和它的距离小于其星值的城市可以买一张票就到达。在所有城市中找出一个城市作为中心城市,满足能够买一张票到达所有公交路线中的城市的条件下,其星值最小。

 基本思路是:从每条路线上的每个地区z出发,进行bfs遍历;对每个地区j,如果j是最终求得的中心地区,则要保证求得的中心地区能到达每条路线上每个地区z,并且选择的星形阈值要尽可能小,因此统计每条路线上每个地区z到地区j最短距离中的最大值,这个最大值记录在数组res[j]中;最后求得的最小星阈值就是每个地区j的res[j]的最小值.

中心地区就是取得最下值的地区j.

代码如下:

#include<stdio.h>
#include<string.h>
#include<queue>
#define ZMAX 10000
#define INF 100000
using namespace std;
int nz,nr;//nz表示公交的数目,nr表示路线 
int mz[ZMAX];//mz[i]为与第i个地区相邻的地区数目 
int Edge[ZMAX][10];
int res[ZMAX];//res[i]表示每条线路上每个地区i距离的的最大值 
int cur;//
int reach[ZMAX];//reach[s]==cur表示地区s在第cur+1站已访问过 
int max(int x,int y)
{
    return (x>y)?x:y;
}
void BFS(int s)
{
    int i,a,b;
    int val,at;//val用于记录层数,即距离;at用于表示BFS过程中的当前结点 
    queue<int>q[2];//滚动队列 
    a=0;b=1;val=0;
    //if(reach[s]<cur)
//    {
        q[b].push(s);
        reach[s]=cur;
        res[s]=max(res[s],val+1);
    //}
    while(!q[b].empty())
    {
        swap(a,b);//不可以用数值代替
        val++;
        while(!q[a].empty())
        {
            at = q[a].front() ;
            q[a].pop();
            for(i=0;i<mz[at];i++)
            {
                if(reach[Edge[at][i]]<cur)
                {
                    q[b].push(Edge[at][i]);
                    reach[Edge[at][i]]=cur;
                    res[Edge[at][i]]=max(res[Edge[at][i]],val+1);
                }
            }
        }
    }
    
}
int main()
{
    int T;
    int i,j,t;
    int id;
    int mr;
    int ret,center;
    scanf("%d",&T);
    while(T--)
    {
        memset(reach,-1,sizeof(reach));
        memset(res,0,sizeof(res));
        cur=0;
        scanf("%d%d",&nz,&nr);
        for(i=0;i<nz;i++)
        {
            scanf("%d",&id);
            scanf("%d",&mz[id]);
            for(j=0;j<mz[id];j++)
            scanf("%d",&Edge[id][j]);
        }
        for(i=0;i<nr;i++)
        {
            scanf("%d",&mr);
            for(j=0;j<mr;j++)
            {
                scanf("%d",&id);
                BFS(id);
                cur++;
            }
        }
        ret=INF;center=-1;
        for(i=0;i<10000;i++)
        {
            if(reach[i]==cur-1&&res[i]<ret)//因为编号不一定是连续的 
            {
                ret=res[i];
                center=i;
                //break;
            }
        }
        printf("%d %d\n",ret,center);
    }
    return 0;
}


 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值