FUZoj--2150(两个起点遍历)

Problem 2150 Fire Game

Accept: 1111    Submit: 3966
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

 Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

 Sample Input

43 3.#.###.#.3 3.#.#.#.#.3 3...#.#...3 3###..##.#

 Sample Output

Case 1: 1Case 2: -1Case 3: 0Case 4: 2
解题思路:好题目,两个起点遍历问题,一开始写,画了几组例子,找出了规律.写了后WA了,原来这含有贪心的思想,先从含有相邻草多的草格子开始烧。不过当时写的时候,那个规律很多例子都满足,最后终于找到了Wa的测试数据,如下:
100
3 7
.#...#.
.######
.....#.
Case 1: 3
正确答案:Case 1: 2 不是简单的规律,含有贪心思想,先烧相邻草较多的地方 

最后换成用bfs()遍历每一种情况,AC了。

代码如下:
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
int mark[15][15];
int vist[15][15];
int n,m;
struct stu{
	int x,y,t;
};
stu node[110];
int dis[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool check(stu temp){
	if(temp.x<0||temp.y<0||temp.x>=n||temp.y>=m)return false;
	else if(vist[temp.x][temp.y])return false;
	else if(mark[temp.x][temp.y]=='.')return false;
	return true;
}
int  bfs(int l,int r){
	queue<stu>q;
	memset(vist,0,sizeof(vist));
	while(!q.empty()){
		q.pop();
	}
    stu temp,star;
    q.push(node[l]);
    q.push(node[r]);
    vist[node[l].x][node[l].y]=1;
    vist[node[r].x][node[r].y]=1;
    while(!q.empty()){
    	star=q.front();
    	q.pop();
    	for(int i=0;i<4;i++){
    		temp=star;
    		temp.t++;
    		temp.x+=dis[i][0];
    		temp.y+=dis[i][1];
    	    if(check(temp)){
    	    	q.push(temp);
    	    	vist[temp.x][temp.y]=1;
    	    }
		}
    }
    for(int i=0;i<n;i++){
    	for(int j=0;j<m;j++){
    		if(!vist[i][j]&&mark[i][j]=='#'){
    			return INF;
    		}
    	}
    }
    return star.t;
}
int main(){
	int k,cas;
	int t;
	cas=1;
	scanf("%d",&t);
	while(t--){
		k=0;
		scanf("%d%d",&n,&m);
	    for(int i=0;i<n;i++){
	    	getchar();
	    	for(int j=0;j<m;j++){
	    		scanf("%c",&mark[i][j]);
	    	    if(mark[i][j]=='#'){
	    	       node[++k].x=i;
				   node[k].y=j;
				   node[k].t=0;	
	    	    }
			}
	    }
	    //printf("%d %d %d\n",node[2].x,node[2].y,node[2].t);
	    int ans=INF;
	    int sum;
	    for(int i=1;i<=k;i++){
	    	for(int j=i;j<=k;j++){
	    	      sum=bfs(i,j);//i==j时,就相当于 只有一个人放火 
				  if(ans>sum)ans=sum;	
	    	}
	    }
		if(ans>=INF)printf("Case %d: -1\n",cas++);
	    else printf("Case %d: %d\n",cas++,ans);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值