hdu--2674

Description

WhereIsHeroFrom:             Zty, what are you doing ? 
Zty:                                     I want to calculate N!...... 
WhereIsHeroFrom:             So easy! How big N is ? 
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000… 
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao? 
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009 


Hint : 0! = 1, N! = N*(N-1)! 
 

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file. 
 

Output

For each case, output N! mod 2009 
 

Sample Input

    
    
4 5
 

Sample Output

    
    
24 120
 
解体思路:(1*2*3*4..............*n)%2009=((.....((1%2009)*2)%2009.....)*n)%2009;又2009=7*7*41,所以比41大的数结果都为0;问题缩小到了41。接下来处理问题就变得简单多了。

代码如下:
#include<stdio.h>
#include<string.h>
int main(){
	long long n,m;
	while(scanf("%lld",&n)!=EOF){
		if(n>=41){
			printf("0\n");
            continue;
		}
		else if(n==0){
			printf("1\n");
		}
		else {
			m=1;
			for(int i=1;i<=n;i++){
				m=(m*i)%2009;
			}
			printf("%d\n",m%2009);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值