N!Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4266 Accepted Submission(s): 2278
Problem Description
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!......
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009
Hint : 0! = 1, N! = N*(N-1)!
Zty: I want to calculate N!......
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009
Hint : 0! = 1, N! = N*(N-1)!
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input
4 5
Sample Output
24 120
Author
WhereIsHeroFrom
Source
解题思路
根据阶乘的性质我们可以知道当阶乘数超过2009时,阶乘最后对2009取余时都等于0。另外注意for循环的结果都要对2009取余,否则有可能溢出。
#include<stdio.h>
int main()
{
int a;
while(scanf("%d",&a)!=EOF)
{
int s=1;
if(a>2009)
{
printf("0\n");
}
else
{
for(int i=1;i<=a;i++)
{
s*=i;
s=s%2009;
}
printf("%d\n",s);
}
}
return 0;
}