hdu--2138

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14698    Accepted Submission(s): 5098


Problem Description
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output
  For each case, print the number of prime numbers you have found out.
 

Sample Input
  
  
3 2 3 4
 

Sample Output

2

解题思路:并不是所有的求素数都打表的,打表是用来求一段区间的,这里是离散的数值,只要暴力判断就行了.

代码如下:

#include<stdio.h>
#include<cmath>
int main(){
	int t;
	int flag,sum,n;
	while(scanf("%d",&t)!=EOF){
      sum=0;
		for(int i=1;i<=t;i++){
			flag=0;
			scanf("%d",&n);
			for(int j=2;j<=sqrt(n);j++){
				if(n%j==0){
					flag=1;
					break;
				}
			}
			if(!flag)sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值