hdu2138素数

43 篇文章 0 订阅

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14684    Accepted Submission(s): 5091


Problem Description
  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output
  For each case, print the number of prime numbers you have found out.
 

Sample Input
  
  
3 2 3 4
 

Sample Output
  
  
2
AC代码:
//hdu-2138素数
//坑爹的水题;本来以为不打表会超时;没想到打表就数组越界;后来请教了
//其他人人才知道就是直接可以暴力过。亥,。。。 
#include<stdio.h>
#include<string.h>
#include<math.h>
bool Is_prim(int x)
{
	if(x==1) return false;
	else
	{
		int i,m;
		m=sqrt(x);
		for(i=2;i<=m;i++)
		 if(x%i==0)
		  return false;
    return true;
	}
}
int main()
{
	int n,a,ans;
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			if(Is_prim(a))
			 ans++;
		} 
		printf("%d\n",ans);
	} 
return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值