hdu--1495

非常可乐

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8613    Accepted Submission(s): 3413


Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

Sample Input
  
  
7 4 3 4 1 3 0 0 0
 

Sample Output
  
  
NO 3
 

Author
seeyou

解题思路:有6种倒法,把这六种倒法看成是走迷宫时的六个方向,问题就转换成了简单的bfs();奇数时一定不能平分,这样就可以首先排除一部分。

代码如下:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int s,n,m,ans;
int c[110][110];
struct stu{
	int sum,x,y,t;
};
bool check(int i,stu star,stu &temp){
	if(star.sum<0||star.x<0||star.y<0||star.x+star.y>s)return false;//边界 
	if(i==1){//s->n
		if(star.x>=n||star.sum==0)return false;
		else{
			if(n-star.x>=star.sum){
				temp.x=star.x+star.sum;
				temp.sum=0;
			}
			else{
				temp.x=n;
				temp.sum=star.sum-(n-star.x);
			} 
			temp.y=star.y;
		}
	}
	else if(i==2){//s->m
		if(star.y>=m||star.sum==0)return false;
		else {
			if(m-star.y>=star.sum){
				temp.y=star.y+star.sum;
				temp.sum=0;
			}
			else{
				temp.y=m;
				temp.sum=star.sum-(m-star.y);
				
			} 
			temp.x =star.x;
		}
	}
	else if(i==3){//n->m
		if(star.x==0||star.y>=m)return false;
		else {
			if(m-star.y>=star.x){
				temp.y=star.y+star.x;
				temp.x=0;
			}
			else{
				temp.y=m;
				temp.x=star.x-(m-star.y);
			}
			temp.sum=star.sum;
		}
	}
	else if(i==4){//n->s
		if(star.x==0||star.sum>=s)return false;
		else{
				temp.sum=star.x+star.sum;
				temp.x=0;
				temp.y=star.y;
			}
	}
	else if(i==5){//m->s
		if(star.y==0||star.sum>=s)return false;
		else{
			temp.sum=star.y+star.sum;
		    temp.y=0;
		    temp.x=star.x;
		}
		
	}
	else if(i==6){//m->n
		if(star.y==0||star.x>=n)return false;
		else{
		if(n-star.x>=star.y){
				temp.x=star.x+star.y;
				temp.y=0;
			}
			else{
				temp.x=n;
				temp.y=star.y-(n-star.x);
			}
			temp.sum=star.sum;
		}
	}
	if(c[temp.x][temp.y])return false;
	temp.t=star.t+1;
	return true;
}
void bfs(){
	memset(c,0,sizeof(c));
	c[0][0]=1;
	queue<stu>q;
	while(!q.empty() ){
		q.pop();
	}
	stu temp,star;
	temp.sum=s;temp.x=0;temp.y=0;temp.t=0;
	q.push(temp);
	while(!q.empty()){
		star=q.front();
		q.pop();
		for(int i=1;i<=6;i++){
			if(check(i,star,temp)){
				if((temp.x==temp.y&&temp.sum==0)||(temp.x==temp.sum&&temp.y==0)||(temp.y==temp.sum&&temp.x==0)){
					ans=temp.t;
					return ;
				}
				c[temp.x][temp.y]=1;
				q.push(temp);
				
			}
		}
	}
}
int main(){
	while(scanf("%d%d%d",&s,&n,&m)){
		if(s==0&&n==0&&m==0)break;
		ans=-1;
		if(s%2){
			printf("NO\n");
			continue;
		}
		bfs();
		if(ans==-1)printf("NO\n");
		else printf("%d\n",ans);
	}
	return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值