poj--2184(0-1背包,体积为负的情况)

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10963 Accepted: 4348

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

解体思路:涉及到一件物品取或是不取,将si看作是体积,fi看作是价值,优化后再判断一下情况是否合理就可以了,但此处出现了体积为负的情况,需要分开讨论。

代码如下:

#include<stdio.h>
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
int dp[200000+10];
int value[110];
int weight[110];
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<n;i++)
		scanf("%d%d",&value[i],&weight[i]);
		int k=100000;//原点
		for(int i=0;i<=200000;i++)dp[i]=-INF;
		dp[k]=0;
		for(int i=0;i<n;i++){
			if(value[i]>0){
				for(int j=200000;j>=value[i];j--)//正的逆循环
				if(dp[j-value[i]]>-INF)
				dp[j]=max(dp[j],dp[j-value[i]]+weight[i]);
			}
			else{
				for(int j=0;j<=200000+value[i];j++)//负的顺循环
				if(dp[j-value[i]]>-INF)
				dp[j]=max(dp[j],dp[j-value[i]]+weight[i]);
			}
		}
		int ans=0;
		for(int i=100000;i<=200000;i++)//从原点开始筛选
			if(dp[i]>=0&&dp[i]+i-100000>ans)//i-100000表示si
			ans=dp[i]+i-100000;
			printf("%d\n",ans);
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值