poj2184 负容量01背包

31 篇文章 0 订阅
27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2184

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10296 Accepted: 4024

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

Source

 

 

 

思路:将每一组数据作为一个物品,TS是容量,TF是价值。由于要求TS和TF必须》=0,但是给的数据出现负数,TS的区间易求得【-100000,100000】,因此将区间平移,注意是平移,我一开始使用1对应-1,二对应-2.。。。。。最后发现区间不连续转移过程无法进行。

然后还有一点就是当处理 这一个数据容量v为负数,f[i-v]>i,而01背包是从上衣状态小容量去推,因此将这里的i按照倒叙循环,可以解决。

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define MAXN 105
#define MAXV 100005
#define max(a,b)(a>b?a:b)
#define INF 0x0fffffff

struct node
{
 int c,w;
};
node a[MAXN];
int f[MAXV*2];

int p=100000;

int main()
{
 //freopen("C:\\1.txt","r",stdin);
 int n;
 cin>>n;
 int i,j;
 for(i=0;i<MAXV*2;i++)
  f[i]=-INF;
 f[p]=0;
 for(i=0;i<n;i++)
  cin>>a[i].c>>a[i].w;
 for(i=0;i<n;i++)
 {
  if(a[i].c>=0)
  {
   for(j=200000;j>=a[i].c;j--)
    if(f[j-a[i].c]!=-INF)
     f[j]=max(f[j],f[j-a[i].c]+a[i].w);
  }
  else
  {
   for(j=0;j<=200000+a[i].c;j++)
    if(f[j-a[i].c]!=-INF)
     f[j]=max(f[j],f[j-a[i].c]+a[i].w);
  }
 }
 int res=0;
 for(i=p;i<=200000;i++)
  if(f[i]>=0)
   res=max(res,f[i]+i-p);
 cout<<res<<endl;
 return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值