杭电 OJ 1323 Perfection

Perfection

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3006    Accepted Submission(s): 1838


Problem Description
From the article Number Theory in the 1994 Microsoft Encarta: "If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant." 
Given a number, determine if it is perfect, abundant, or deficient. 
 

Input
A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.
 

Output
The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.
 

Sample Input
  
  
15 28 6 56 60000 22 496 0
 

Sample Output
  
  
PERFECTION OUTPUT 15 DEFICIENT 28 PERFECT 6 PERFECT 56 ABUNDANT 60000 ABUNDANT 22 DEFICIENT 496 PERFECT END OF OUTPUT
刚开始说的是什么是奇数,什么是偶数,个人感觉没什么用。这题意思就是看一个数是不是完美数,是就输出 PERFECT,不是,除数大于本身的话,输出ABUNDANT,不然输出DEFICIENT。微笑下面是代码:

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

    int N;

    cout <<"PERFECTION OUTPUT"<<endl;

    while(cin>>N,N)

    {

        int sum=0;

        for(int i=1;i<=N/2;i++)   //刚开始直接就通到N

        {

            if(N%i==0)

                sum+=i;

        }

        //cout <<"PERFECTION OUTPUT"<<endl;

//printf("%5d",N);//这样写也行

        cout<<setw(5)<<N; //注意输出格式,是总共占据五个字符空间。

            if(sum<N)

                cout <<"  DEFICIENT"<<endl;

            if(sum==N)

                cout <<"  PERFECT"<<endl;

            if(sum>N)

                cout <<"  ABUNDANT"<<endl;

            

    }

    cout<<"END OF OUTPUT"<<endl;

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值