ACM--Perfection

Perfection

Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 1410, Accepted users: 1181
Problem 10051 : No special judgement

Problem description

From the article Number Theory in the 1994 Microsoft Encarta: ``If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."
Given a number, determine if it is perfect, abundant, or deficient.

Input

A list of N positive integers (none greater than 60,000), with 1 < N < 400. A 0 will mark the end of the list.

Output

The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

Sample Input

15 28 6 56 60000 22 496 0

Sample Output

PERFECTION OUTPUT
15 DEFICIENT
28 PERFECT
6 PERFECT
56 ABUNDANT
60000 ABUNDANT
22 DEFICIENT
496 PERFECT
END OF OUTPUT


分析

这个题目不难,就是除开自己的因数相加,再与自己进行比较,但是这里有一个坑,很容易被人忽略掉的就是,1的因子是1本身,所以1的sum=0而不是1
最开始我是这样写的,就一直通不过

int sum=1; 
		for(int i=2;i<t;i++){
			if(t%i==0){
				sum+=i;
			}
		}

因为就是忽略了t=1的情况,如果t=1,不会进入for循环,sum直接等于1,判断错误
在上述代码后加上这样,把t=1当做特殊情况考虑,就正确了


		if(t==1)
		sum=0;

还有一个坑就是格式的输出,这个记住就好啦!

写法一的完整代码:

#include<iostream>
#include<iomanip>
#include<cmath>
using namespace std;
int main(){
	int t;
	cout<<"PERFECTION OUTPUT"<<'\n';
	while(cin>>t,t!=0){
		cout<<setfill(' ')<<setw(5)<<t<<"  ";
		
		
		int sum=1; 
		for(int i=2;i<t;i++){
			if(t%i==0){
				sum+=i;
			}
		}
		if(t==1)
		sum=0;
 	
		
		if(sum>t)
		cout<<"ABUNDANT"<<'\n';
		else if(sum<t)
		cout<<"DEFICIENT"<<'\n';
		else
		cout<<"PERFECT"<<'\n';
	}
	cout<<"END OF OUTPUT"<<'\n';
}





写法二

还有一种思路,就是最开始把sum=0,i++改为++i,把t是否能被1整除的计算过程包含进去
完整地代码如下:

#include<iostream>
#include<iomanip>
#include<cmath>
using namespace std;
int main(){
	int t;
	cout<<"PERFECTION OUTPUT"<<'\n';
	while(cin>>t,t!=0){
		cout<<setfill(' ')<<setw(5)<<t<<"  ";
		
	
 
		int sum=0;
		for(int i=1;i<t;++i){
			if(t%i==0)
			sum+=i;
		} 
	
		
		
		if(sum>t)
		cout<<"ABUNDANT"<<'\n';
		else if(sum<t)
		cout<<"DEFICIENT"<<'\n';
		else
		cout<<"PERFECT"<<'\n';
	}
	cout<<"END OF OUTPUT"<<'\n';
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

MORE_77

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值