HDU-幂次方取尾数

79 篇文章 0 订阅
问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:Given a positive integer N, you should output the most right digit of N^N.
*程序输入:The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
*程序输出:For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6. 
*/
#include <iostream>
using namespace std;
int main()
{
    int n,m,f,i,t;
    cin>>t;
    while(t--)
    {
        while(cin>>n)
        {
            f=n%10;
            if(n%4==0)
                n=4;
            else n%=4;
            m=1;
            for(i=0; i<n; i++)
                m*=f;
            cout<<m%10<<endl;
        }
    }
    return 0;
}



运行结果:


知识点总结:

找规律。


任何数的n次幂的个位都有一个周期是4。



学习心得:

任何数的n次幂的个位都有一个周期是4,找到规律就好写了,暴力破解容易超时。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值