问题及代码:
运行结果:
知识点总结:
/*
*Copyright (c)2014,烟台大学计算机与控制工程学院
*All rights reserved.
*文件名称:HDU.cpp
*作 者:单昕昕
*完成日期:2015年1月27日
*版 本 号:v1.0
*问题描述:Given a positive integer N, you should output the most right digit of N^N.
*程序输入:The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
*程序输出:For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
*/
#include <iostream>
using namespace std;
int main()
{
int n,m,f,i,t;
cin>>t;
while(t--)
{
while(cin>>n)
{
f=n%10;
if(n%4==0)
n=4;
else n%=4;
m=1;
for(i=0; i<n; i++)
m*=f;
cout<<m%10<<endl;
}
}
return 0;
}
运行结果:
知识点总结:
找规律。
任何数的n次幂的个位都有一个周期是4。
学习心得:
任何数的n次幂的个位都有一个周期是4,找到规律就好写了,暴力破解容易超时。