BestCoder-四条边是否能组成四边形

CA Loves Stick

Accepts: 381
Submissions: 3204
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)
Problem Description

CA loves to play with sticks.One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.(What is quadrilateral? Click here:https://en.wikipedia.org/wiki/Quadrilateral)

Input

First line contains TTT denoting the number of testcases.TTT testcases follow. Each testcase contains four integers a,b,c,da,b,c,da,b,c,d in a line, denoting the length of sticks.1≤T≤1000, 0≤a,b,c,d≤263−11 \le T \le 1000,~0 \le a,b,c,d \le 2^{63}-11T1000, 0a,b,c,d2631

Output

For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).

Sample Input
2
1 1 1 1
1 1 9 2
Sample Output
Yes
No

四条边能组成四边形:最长边小于其余三条边的和

#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
#include<algorithm>
using namespace std;

int main()
{
    int ca,i;
    scanf("%d",&ca);
    unsigned long long a[4];
    while(ca--)
    {
        for(i=0; i<4; ++i)
            cin>>a[i];
        sort(a,a+4);
        if((a[0]>a[3]-a[2]-a[1])&&a[0]!=0&&a[1]!=0&&a[2]!=0&&a[3]!=0)//最大边大于剩下三边之和,注意longlong相加会超长度!!还有注意边长为0的情况!!
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值