HDU-求大数的阶乘

79 篇文章 0 订阅
6 篇文章 0 订阅
问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
*程序输入:One N in one line, process to the end of file.
*程序输出:For each N, output N! in one line.

Sample Input
1
2
3

Sample Output
1
2
6
*/
#include<iostream>
#include<cstdio>
using namespace std;
int a[40000];
int main()
{
    int i,j,n,carry;
    while(~scanf("%d",&n))
    {
        a[0]=1,a[1]=1;
        if(n==0 || n==1)
        {
            printf("1\n");
            continue;
        }
        for(i=2; i<=n; ++i)
        {
            carry=0;
            for(j=1; j<=a[0]; ++j)
            {
                int temp=a[j]*i+carry;
                carry=temp/10;
                a[j]=temp%10;
            }
            while(carry)
            {
                a[j]=carry%10;
                a[0]=j;
                carry/=10;
                j++;
            }
        }
        for(i=a[0]; i>=1; --i)
            printf("%d",a[i]);
        puts("");
    }
    return 0;
}



运行结果:


知识点总结:
求大数的阶乘,要分离开一部分一部分做。

学习心得:

千万不要想着能暴力破解,我试着用unsigned long long型来测试最大数据长度,结果最大只能算到65!,再大的话就显示是0了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值