HDOJ-----1042阶乘

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2

6

输入n,求n的n次方

#include<cstdio>
int a[10010];
int main(){
    int n,i,j,c,t;
    while(~scanf("%d", &n)){
		a[0] = 1;
 		t = 0;
 		for(i = 1; i <= n; ++i){//每个数组单位存五位数字,即字节byte与位bit的关系,一个a[i]储存*****五位数字
		 	c = 0;
			for(j = 0; j <= t; ++j){
				a[j] = a[j]*i + c;//c是进位的值,t表示第几个单位,即第几个储存五位数字的单位
				c = a[j] / 100000;//与100000运算,满五向前进位,100000只是个基数,换成1000000即一个单位储存六位数字
				a[j] %= 100000;
			}
 			if(c != 0){
			 	t++;
				a[t] = c;
			}
		}
		printf("%d", a[t]);//最高位不一定满五位,不能用%05d输出,单独输出
		for( i = t - 1; i >= 0; i--){
			printf("%05d",a[i]);
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值