HDU-最大公倍数-多个数

79 篇文章 0 订阅
问题及代码:
/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
*程序输入:Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

The final input line will contain a single zero on a line by itself.
*程序输出:For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296
*/
#include<iostream>
using namespace std;
unsigned long long gcd(unsigned long long a,unsigned long long b)
{
    return (a%b!=0?(gcd(b,a%b)):b);
}
unsigned long long lcm(unsigned long long u,unsigned long long v)
{
    unsigned long long h;
    h=gcd(u,v);
    return(u*v/h);
}
unsigned long long a[100000];
int main()
{
    unsigned long long t,n,temp,i;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0; i<n; i++)
            cin>>a[i];
        temp=a[0];
        for(i=1; i<n; i++)
        {
            temp=lcm(temp,a[i]);
        }
        cout<<temp<<endl;
    }
    return 0;
}



运行结果:


知识点总结:
多个数的最大公倍数。

学习心得:

用数组保存,两两取就好了嘛。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值