HDU-小盒子放在格子里-可以旋转

79 篇文章 0 订阅
问题及代码:
/* 
*Copyright (c)2014,烟台大学计算机与控制工程学院 
*All rights reserved. 
*文件名称:objection.cpp 
*作    者:单昕昕 
*完成日期:2015年2月3日 
*版 本 号:v1.0 
* 
*问题描述:There is a large room in the Pyramid called Room-of-No-Return. Its floor is covered by rectangular tiles of equal size. The name of the room was chosen because of the very high number of traps and mechanisms in it. The ACM group has spent several years studying the secret plan of this room. It has made a clever plan to avoid all the traps. A specially trained mechanic was sent to deactivate the most feared trap called Shattered Bones. After deactivating the trap the mechanic had to escape from the room. It is very important to step on the center of the tiles only; he must not touch the edges. One wrong step and a large rock falls from the ceiling squashing the mechanic like a pancake. After deactivating the trap, he realized a horrible thing: the ACM plan did not take his equipment box into consideration. The box must be laid onto the ground because the mechanic must have both hands free to prevent contact with other traps. But when the box is laid on the ground, it could touch the line separating the tiles. And this is the main problem you are to solve.
*程序输入:The input consists of T test cases. The number of them (T) is given on the first line of the input. Each test case consists of a single line. The line contains exactly four integer numbers separated by spaces: A, B, X and Y. A and Bindicate the dimensions of the tiles, X and Y are the dimensions of the equipment box (1 <= A, B, X, Y <= 50000). 
*程序输出:Your task is to determine whether it is possible to put the box on a single tile -- that is, if the whole box fits on a single tile without touching its border. If so, you are to print one line with the sentence "Escape is possible.". Otherwise print the sentence "Box cannot be dropped.". 
Sample Input
2
10 10 8 8
8 8 10 10
Sample Output
Escape is possible.
Box cannot be dropped.
*/ 
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int test(double a,double b,double x,double y)
{

    if(a*b<x*y)
        return 0;
    if(a>x&&b>y)
        return 1;
    if(b<=y)
        return 0;

    double d=sqrt(x*x+y*y);
    double angle=acos(y/d)-acos(b/d);
    double h=x*cos(angle)+y*sin(angle);
    if(h>a)
        return 0;
    else
        return 1;
}
int main()
{
    int i,j;
    double a,b,x,y;
    int t;
    scanf("%d",&t);
    while(t--)
    {

        cin>>a>>b>>x>>y;
        if(a<b)
            swap(a,b);
        if(x<y)
            swap(x,y);
        if(test(a,b,x,y))
            printf("Escape is possible.\n");
        else
            printf("Box cannot be dropped.\n");
    }
    return 0;
}



运行结果:


知识点总结:
注意分四种情况考虑,特别讨论可以旋转放置的情况。




学习心得:

C++又超时了,我只能用C语言提交了。。

讨论可以旋转放置的情况,我参考了大神的代码,新技能get~!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值