HDU-Can you solve this equation? -二分法求高次方程近似解

79 篇文章 0 订阅
问题及代码:

Problem F Can you solve this equation? 

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!


/*    
*Copyright (c)2015,烟台大学计算机与控制工程学院    
*All rights reserved.    
*文件名称:HDU.cpp    
*作    者:单昕昕    
*完成日期:2015年2月27日    
*版 本 号:v1.0        
*/ 
#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;
double f(double x)
{
    return (8*x*x*x*x+7*x*x*x+2*x*x+3*x+6);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        double y,m=0.0,n=100.0;
        cin>>y;
        if(f(0)>y||f(100)<y)
        {
            cout<<"No solution!"<<endl;
            continue;
        }
        double mid=50.0;
        while(fabs(f(mid)-y)>1e-5)
        {
            if((f(mid)>y))
            {
                n=mid;
                mid=(m+n)/2;
            }
            else if(f(mid)<y)
            {
                m=mid;
                mid=(m+n)/2;
            }
        }
        printf("%.4lf\n",mid);
    }
    return 0;
}



运行结果:



知识点总结:
二分法求高次方程近似解。

学习心得:

主要是二分的思想,用一个自定义函数不断逼近方程的解。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值