HUST 1010-The Minimum Length-KMP

The Minimum Length
Time Limit:1000MS    Memory Limit:131072KB    64bit IO Format:%lld & %llu

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7



有一个字符串,长度小于1000000。我一遍又一遍的重写。然后我有了一个新的字符串:aaaaaa ......现在我把它从两个不同的位置,得到一个新的字符串,然后,给你的字符串B,你能告诉我,例如最短的字符串的长度,A="abcdefg". I got abcdefgabcdefgabcdefgabcdefg....…然后我把红色部分:efgabcdefgabcde作为字符串B,你应该找出最短的A.

多试验例。每一行有一个字符串B只包含小写和大写。长度不超过1000000。


#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxt=1000000+10;
char t[maxt];
int next[maxt];
int main()
{
    while(scanf("%s",t)!=EOF)
    {
        int p=0,cur,l;
        next[0]=-1;
        next[1]=0;
        l=strlen(t);
        for(cur=2; cur<=l; ++cur)
        {
            while(p>=0&&t[p]!=t[cur-1])
                p=next[p];
            next[cur]=++p;
        }
        printf("%d\n",l-next[l]);
    }
    return 0;
}

KMP模板题,调用求子模板串的模式值next[n],再用串的长度减去next[n]即得到答案。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值