山东省第一届ACM大学生程序设计竞赛-Balloons(搜索)

问题及代码:

Balloons

Time Limit: 1000MS Memory limit: 65536K

题目描述

Both Saya and Kudo like balloons. One day, they heard that in the central park, there will be thousands of people fly balloons to pattern a big image.
They were very interested about this event, and also curious about the image.
Since there are too many balloons, it is very hard for them to compute anything they need. Can you help them?
You can assume that the image is an N*N matrix, while each element can be either balloons or blank.
Suppose element A and element B are both balloons. They are connected if:
i) They are adjacent;
ii) There is a list of element C1,C2, … ,Cn, whileA andC1 are connected,C1 andC2 are connected …Cn and B are connected.
And a connected block means that every pair of elements in the block is connected, while any element in the block is not connected with any element out of the block.
To Saya, element A(xa,ya)and B(xb,yb) is adjacent if |xa-xb| + |ya-yb|  1 
But to Kudo, element A(xa,ya) and element B (xb,yb) is adjacent if |xa-xb|≤1 and |ya-yb|1
They want to know that there’s how many connected blocks with there own definition of adjacent?

输入

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N100), which represents the size of the matrix.
Each of the next N lines contains a string whose length is N, represents the elements of the matrix. The string only consists of 0 and 1, while 0 represents a block and 1represents balloons.
The last case is followed by a line containing one zero.

输出

 For each case, print the case number (1, 2 …) and the connected block’s numbers with Saya and Kudo’s definition. Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

5
11001
00100
11111
11010
10010

0

示例输出

Case 1: 3 2

提示

来源

 2010年山东省第一届ACM大学生程序设计竞赛


题意:

输入一个n行n列的矩阵,其中:0 represents a block and 1represents balloons

根据以下条件

To Saya, elementA(xa,ya)and B(xb,yb) is adjacent if |xa-xb| + |ya-yb|  1  表示是上下左右四个方向;
But to Kudo, element A(xa,ya) and element B (xb,yb) is adjacent if |xa-xb|≤1 and |ya-yb|1 表示是上下左右对角八个方向;

判断连接在一起的“1”块有几组。



/*
* Copyright (c) 2016, 烟台大学计算机与控制工程学院
* All rights reserved.
* 文件名称:dfs.cpp
* 作    者:单昕昕
* 完成日期:2016年4月1日
* 版 本 号:v1.0
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
using namespace std;
int book[101][101];
int Map[101][101];
int n,tx,ty;
int move1_x[4]= {0,1,0,-1};
int move1_y[4]= {-1,0,1,0};
int move2_x[8]= {-1,0,1,1,1,0,-1,-1};
int move2_y[8]= {-1,-1,-1,0,1,1,1,0};
void dfs1(int x,int y)
{
    int i;
    if (Map[x][y]==1&&book[x][y]==false)
    {
        book[x][y]=true;
        for(i=0; i<4; i++)
        {
            tx=x+move1_x[i];//计算坐标
            ty=y+move1_y[i];
            if (tx>=0&&ty>=0&&tx<n&&ty<n&&Map[tx][ty]==1&&book[tx][ty]==false)
            {
                dfs1(tx,ty);
            }
        }
        return ;
    }
}

void dfs2(int x,int y)
{
    int i;
    if (Map[x][y]==1&&book[x][y]==false)
    {
        book[x][y]=true;
        for(i=0; i<8; i++)
        {
            tx=x+move2_x[i];//计算坐标
            ty=y+move2_y[i];
            if (tx>=0&&ty>=0&&tx<n&&ty<n&&Map[tx][ty]==1&&book[tx][ty]==false)
            {
                dfs2(tx,ty);
            }
        }
        return ;
    }
}

int main()
{
    int Case=0;
    while(cin>>n&&n!=0)
    {
        memset(book,false,sizeof(book));
        int i,j,sum1=0,sum2=0;
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                cin >> Map[i][j];
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
            {
                if(Map[i][j]==1&&book[i][j]==false)
                {
                    dfs1(i,j);
                    ++sum1;
                }
            }
        memset(book,false,sizeof(book));
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
            {
                if(Map[i][j]==1&&book[i][j]==false)
                {
                    dfs2(i,j);
                    ++sum2;
                }
            }
        cout<<"Case "<<++Case<<": "<<endl;
        cout<<sum1<<" "<<sum2<<endl;
    }
    return 0;
}
/*
5
1 1 0 0 1
0 0 1 0 0
1 1 1 1 1
1 1 0 1 0
1 0 0 1 0
*/

运行结果:


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值