HDU - 5655 CA Loves Stick(竟有四边形判定定理。。。)

CA loves to play with sticks. 
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral. 
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
Input
First line contains  T T denoting the number of testcases. 
T T testcases follow. Each testcase contains four integers  a,b,c,d a,b,c,d in a line, denoting the length of sticks. 
1T1000, 0a,b,c,d≤ 2631 1≤T≤1000, 0≤a,b,c,d≤263−1
Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
Sample Input
2
1 1 1 1
1 1 9 2
Sample Output
Yes
No

题意:判断能否组成四边形。

quadrilateral
[ˌkwɒdrɪˈlætərəl] [ˌkwɑ:drɪˈlætərəl]
adj. 四边(形)的;
n. 四边形;
[例句] Isoparametric element of arbitrary quadrilateral plays an important role in finite element analysis.
等参数任意四边形单元在有限元分析中有着重要的作用。
一:不知道这个单词的意思,不会看懂题的。

二:知道这个题什么意思,不一定知道有这么一个定理,判断四边形。

(a<=b<=c<=d)    d<a+b+c;

三:知道前两点也要让你错几次!!!。数据太坑了。。2^63-1,把人往死里坑哭

我用的是d-b-c<a.稍不注意就会数据崩溃。

还要注意0!!!

#include<stdio.h>
#include<algorithm>
using namespace std;
__int64 a[5];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int f=0;
        for(int i=0; i<4; i++)
        {
             scanf("%I64d",&a[i]);
             if(a[i]==0)f=1;
        }
        if(f)
        {
            printf("No\n");
            continue;
        }
        sort(a,a+4);
        if(a[3]-a[2]-a[1]<a[0])
        {
            printf("Yes\n");
        }
        else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值