POJ 3041-Asteroids(二分图匹配)

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20099 Accepted: 10900

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source


题目意思:

N*N的网格中有K颗小行星,小行星i的位置是(Ri,Ci)。现在有一个强力武器能够一发光束将一行或者是一列的小行星轰为灰烬。现在想要利用这个武器摧毁所有的小行星,至少需要多少发光束?

解题思路:

转换为图:把每一行和列都当做一个点,若行列之间有边连接起来就说明这个行列之间有小行星。
光束的攻击方案对应一个顶点集S,而要求攻击的方案能摧毁所有的小行星就是说,图中的每条边都至少有一个属于S的顶点。
这样一来,转换成最小顶点匹配问题。

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <vector>
#define MAXN 5000
using namespace std;

int V,N,K;//二分图顶点数、网格行列数、小行星数
int R[MAXN],C[MAXN];
vector<int>G[MAXN];//图的邻接表表示
int match[MAXN];//所匹配的顶点
bool used[MAXN];//DFS访问标记

void add_edge(int u,int v)//向图中增加一条连接u和v的边
{
    G[u].push_back(v);
    G[v].push_back(u);
}

bool dfs(int v)//dfs寻找增广路
{
    used[v]=true;
    for(int i=0; i<G[v].size(); ++i)
    {
        int u=G[v][i],w=match[u];
        if(w<0||!used[w]&&dfs(w))
        {
            match[v]=u;
            match[u]=v;
            return true;
        }
    }
    return false;
}

int bipartite_matching()//二分图最大匹配
{
    int res=0;
    memset(match,-1,sizeof(match));
    for(int v=0; v<V; ++v)
        if(match[v]<0)
        {
            memset(used,0,sizeof(used));
            if(dfs(v)) ++res;
        }
    return res;
}

void solve()
{
    V=2*N;
    for(int i=0; i<K; ++i)
        add_edge(R[i]-1,N+C[i]-1);
    cout<<bipartite_matching()<<endl;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cin>>N>>K;
    for(int i=0; i<K; ++i)
        cin>>R[i]>>C[i];
    solve();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值