ZOJ 2588-Burning Bridges(割边)

Burning Bridges


Time Limit: 5 Seconds      Memory Limit: 32768 KB


Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?

 

Input

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.

 

Output

On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.

Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.

 

Sample Input

2

 

6 7

1 2

2 3

2 4

5 4

1 3

4 5

3 6

 

10 16

2 6

3 7

6 5

5 9

5 4

1 2

9 8

6 4

2 10

3 8

7 9

1 4

2 4

10 5

1 6

6 10

 

Sample Output

2

3 7

 

1

4

题目意思:

N个岛,M座桥。烧毁尽可能多的桥,但是要保证岛之间的连通性。

输出不会被烧毁的桥的个数,并且输出这些桥的序号。

解题思路:

求割边。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
#define INF 0xfffffff
#define maxn 100010

using namespace std;
struct Node
{
    int j,tag,id;//j是另一个顶点的序号,tag是重边的数量,id是序号
    Node *next;//下一个边结点
};
int n,m;//顶点数、边数
int nid;//输入时边的序号
Node mem[maxn];//存储边结点
int memp;//mem数组中的序号
Node *e[maxn];//邻接表
int bridge[maxn];//如果bride[i]=1,则第i+1条边是割边
int nbridge;//割边的数目
int low[maxn],dfn[maxn];
int vis[maxn];//0-未访问,1-已经访问,2-已经访问且已检查邻接顶点
int add_edge(Node *e[],int i,int j)//在邻接表中插入边(i,j),如果有重边,则相应边结点tag+1
{
    Node *p;
    for(p=e[i]; p!=NULL; p=p->next)
        if(p->j==j) break;
    if(p!=NULL)//是重边
    {
        p->tag++;
        return 0;
    }
    p=&mem[memp++];
    p->j=j;
    p->next=e[i];
    e[i]=p;
    p->id=nid;
    p->tag=0;
    return 1;
}
void dfs(int i,int father,int dth)//i-当前搜索的顶点,father-i的父亲节点,dth-搜索深度
{
    vis[i]=1;
    dfn[i]=low[i]=dth;
    Node *p;
    for(p=e[i]; p!=NULL; p=p->next)
    {
        int j=p->j;
        if(j!=father&&vis[j]==1)
            low[i]=min(low[i],dfn[j]);
        if(vis[j]==0)//未访问
        {
            dfs(j,i,dth+1);
            low[i]=min(low[i],low[j]);
            if(low[j]>dfn[i]&&!p->tag)//重边不可能是割边
                bridge[p->id]=++nbridge;
        }
    }
    vis[i]=2;
}

int main()
{
    int i,j,k,t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memp=0;
        nid=0;
        memset(e,0,sizeof(e));
        for(k=0; k<m; ++k,++nid)//读边存入邻接表
        {
            cin>>i>>j;
            add_edge(e,i-1,j-1);
            add_edge(e,j-1,i-1);
            bridge[nid]=0;
        }
        nbridge=0;
        memset(vis,0,sizeof(vis));
        dfs(0,-1,1);//从根结点0开始DFS
        cout<<nbridge<<endl;//输出割边的信息
        for(i=0,k=nbridge; i<m; ++i)
            if(bridge[i])
            {
                cout<<i+1;
                if(--k) cout<<" ";
            }
        if(nbridge) puts("");
        if(t) puts("");
    }
    return 0;
}
/**
2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10
**/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值