HDU 5879-Cure(1/n^2之和)

25 篇文章 1 订阅

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1274    Accepted Submission(s): 429


Problem Description
Given an integer n , we only want to know the sum of 1/k2 where k from 1 to n .
 

Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n .
The input file is at most 1M.
 

Output
The required sum, rounded to the fifth digits after the decimal point.
 

Sample Input
  
  
1 2 4 8 15
 

Sample Output
  
  
1.00000 1.25000 1.42361 1.52742 1.58044
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5900  5899  5898  5897  5896 

题目意思:

求1/1^2到1/n^2之和,保留5位小数点。

解题思路:

打表预处理,搜出前2000000,因为是 保留5位小数点所以较大的数直接近似成(π^2)/6,即1.64493。

#include<cstdio>
#include<iostream>
#include<vector>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>
#include<set>
#include<queue>
#define INF 0xfffffff
using namespace std;
const int maxn=2000000;
typedef long long ll;


double a[maxn];
char s[maxn*10];
void f()//打表
{
    a[0]=a[1]=1;
    for(int i=2; i<=maxn; ++i)
        a[i]=1/pow(i,2)+a[i-1];
}
int main()
{
    f();
    long long n;
    while(~scanf("%s",s))
    {
        if(strlen(s)<=7)
        {
            sscanf(s,"%I64d",&n);//取最大I64d长度的字符串s转换存入长整型n
            if(n<=1000000)
                printf("%.5lf\n",a[n]);
            else
                printf("1.64493\n");//六分之π平方
        }
        else
            printf("1.64493\n");
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值