HDU - 5879 -Cure

Given an integer nn, we only want to know the sum of 1/k21/k2 where kk from 11 to nn.

Input

There are multiple cases. 
For each test case, there is a single line, containing a single positive integer nn. 
The input file is at most 1M. 

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

题解:这种为避免超时,肯定要提前打表,然后需要哪个值就去除,但是我们不知道给的整数多大,可能有很大的数,但是我们也很清楚,当分母很大的时候,和就趋近不变了,然后就分情况考虑输出就可以了。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
char a[1000006];
double sum[1000006];

int main(void){
    for(int i=1;i<1000006;i++)
	{
        sum[i]=sum[i-1]+(double)1/i/i;
    }
    while(~scanf("%s",a))
	{
        int l=strlen(a);
        if(l>=7){
            printf("%.5lf\n",sum[1000000]);
        }
        else{
            int n=0;
            for(int i=0;i<l;i++){
                n=n*10+a[i]-'0';
            }
            printf("%.5lf\n",sum[n]);
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

black-hole6

你的鼓励将是我创作的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值