POJ 1611-The Suspects(并查集-同一集合)

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 35531 Accepted: 17239

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source


题目意思:

严重急性呼吸综合征(SARS)是一种未知病因的非典型肺炎,在2003年3月中旬被确认为全球性威胁。为了尽量减少对他人的传播,最好的策略是将嫌疑人与他人分开。
在不扩散大学(NSYSU),有很多学生组。同一组中的学生经常互相沟通,学生可以加入几个小组。为了防止SARS的可能传输,NSYSU收集所有学生组的成员列表,并在其标准操作过程(SOP)中制定以下规则:
一旦群组中的成员是可疑人员,群组中的所有成员都是可疑人员。
然而,他们发现,当学生被认定为嫌疑犯时,识别所有嫌疑犯并不容易。你的工作是写一个程序,找到所有的嫌疑犯。

输入文件包含多种情况。每个测试用例以一个行中的两个整数n和m开始,其中n是学生的数量,m是组的数量。您可以假设0 <n <= 30000和0 <= m <= 500。每个学生都使用0和n-1之间的唯一整数进行编号,最初学生0在所有情况下都被识别为可疑人员。此行后面是组的m个成员列表,每个组一行。每行以一个整数k开始,它表示组中的成员数。按照成员数量,有k个整数表示该组中的学生。一行中的所有整数至少由一个空格分隔。
其中n = 0且m = 0的情况下表示输入的结束,并且不需要进行处理。

解题思路:

并查集将学生按分组,然后统计与0号学生在同一组的学生的人数(包括自身)。

#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
int set[50000+5];
int set_find(int p)
{
    if(set[p]==0)
        return p;
    return set[p]=set_find(set[p]);
}
void join(int p,int q)
{
    int p1,q1;
    p1=set_find(p);
    q1=set_find(q);
    if(p1!=q1)
        set[p1]=q1;
}

int main()
{
    int n, m, i, j,ans;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(m==0&&n==0) break;
        ans=0;
        memset(set,0,sizeof(set));
        while(m--)//输入各组
        {
            int t;
            scanf("%d", &t);
            --t;
            scanf("%d",&i);
            while(t--)
            {
                scanf("%d",&j);
                join(i,j);
            }
        }
        for(int i=1; i<n; i++)
            if(set_find(i)==set_find(0))//统计与0号在同一组的人数
                ans++;
        printf("%d\n",++ans);
    }
    return 0;
}
/*
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值