POJ 1265-Area(多边形面积、边点、内点-pick定理、叉积)

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6452 Accepted: 2821

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs dx dy of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing Scenario #i: where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

Source


题目意思:

机器人从原点(0,0)出发,原点不计入多边形。输入n组数据dx和dy,表示机器人向右和向上移动的步数。
求机器人行走的路径所围成的多边形内部的点的数量、边上的点的数量、多边形面积。

解题思路:

①点X(x1,y1)到点Y(x2,y2)的线段上,格点数=gcd(abs(x2-x1),abs(y2-y1))
任意一个多边形的面积等于按顺序求相邻两个点与原点组成的向量的叉积之和
给定顶点坐标均是整点(或正方形格点)的简单多边形,皮克定理说明了其面积S和内部格点数目n、边上格点数目s的关系:
(其中n表示多边形内部的点数,s表示多边形边界上的点数,S表示多边形的面积)

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
using namespace std;

int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
struct point
{
    int x,y;
} p[105];
double circulation(point a,point b,point c)//计算向量BA、CA的叉积
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    int t,ca=0;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        p[0].x=p[0].y=0;//原点
        int I=0,E=0;//内点和边点数量
        double A=0.0;//面积
        for(int i=1; i<=n; ++i)
        {
            scanf("%d%d",&p[i].x,&p[i].y);//移动的坐标
            E+=gcd(abs(p[i].x),abs(p[i].y));//边点
            p[i].x+=p[i-1].x;//移动后的坐标
            p[i].y+=p[i-1].y;
            A+=circulation(p[0],p[i],p[i-1]);//面积
        }
        A=0.5*fabs(A);
        I=A+1-E/2;//内点
        printf("Scenario #%d:\n%d %d %.1f\n\n",++ca,I,E,A);
    }
    return 0;
}
/*
2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值