POJ 1050-To the Max(最大子矩阵和)

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 48640 Accepted: 25719

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


题目意思:

N*N矩阵,求其中一个最大的子矩阵使得其和最大。

解题思路:

转换成一维DP的思路来做,先处理前缀和,对于每一列上的元素,当前元素的值加上其前面所有元素的值。
然后参考一维DP的做法,枚举起始和终止行,在列上找最大值。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 101
int a[MAXN][MAXN];
int b[MAXN];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    cin>>n;
    memset(a,0,sizeof(a));
    for(int i=1; i<=n; ++i)
        for(int j=1; j<=n; ++j)
        {
            cin>>a[i][j];
            a[i][j]+=a[i-1][j];//列上的元素依次求和
        }
    /*for(int i=1; i<=n; ++i)
    {
        for(int j=1; j<=n; ++j)
            cout<<a[i][j]<<" ";
        cout<<endl;
    }*/
    int ans=a[1][1];
    for(int i=0; i<=n-1; ++i)//起始行
        for(int j=i+1; j<=n; ++j)//终止行
        {
            memset(b,0,sizeof(b));//第i~j行k列中能取得的最大值
            for(int k=1; k<=n; ++k)//当前枚举的列
            {
                if(b[k-1]>=0) b[k]=b[k-1]+a[j][k]-a[i][k];
                else b[k]=a[j][k]-a[i][k];
                ans=max(ans,b[k]);
            }
        }
    cout<<ans<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值