Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 0
9 2 -6 2 -4 1 -4 1
-1 8 0 -2
Sample Output
15
这道题实际上是一维最大子序列和的问题在二维矩阵上的扩展。回忆一下,最大子序列和是求一维数组中连续子序列最大和的问题,那么怎么向二维扩展呢?实际上,子矩阵在两个方向上也是连续的。所以可以将这二维的问题转化为一维的,就是可以将子矩阵每一列相加就会得到一个一维的数组,然后可以用一维最大子序列和的方法来求解。剩下的就是要按行遍历所有可能的子矩阵,比较找出其中的最大值。当然,思路是别人的,但是,代码是自己写的。
#include <iostream>
#include<cstdlib>
using namespace std;
int maxsubarray(int *a,int n)
{
int maxn=-1;
int sum=0;
for(int i=0;i<n;i++)
{
sum+=a[i];
if(sum>maxn)
maxn=sum;
if(sum<0)
sum=0;
}
return maxn;
}
int tothemax(int a[][101],int n)
{
int t[101];
int maxsum=0,maxn;
for(int i=0;i<n;i++)
for(int j=0;j<=i;j++)
{
for(int k=0;k<n;k++)
{
t[k]=0;
for(int p=j;p<=i;p++)
t[k]+=a[p][k];
}
maxn=maxsubarray(t,n);
if(maxsum<maxn) maxsum=maxn;
}
return maxsum;
}
int main()
{
int i,j,maxsum;
int N;
cin>>N;
int a[101][101];
for(i=0;i<N;i++)
for(j=0;j<N;j++)
cin>>a[i][j];
maxsum=tothemax(a,N);
cout<<maxsum<<endl;
return 0;
}