POJ 3067-Japan(树状数组-逆序数)

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27557 Accepted: 7455

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source


题目意思:

岛国的东西两侧分别有N和M个城市,从南到北依次编号。
在它们之间修建K条公路,计算这些公路之间的交点数量。

解题思路:

我们先按城市编号升序排列,东侧相同时按西侧升序排列。
这个时候如果一条路和其它路有交点,则Y坐标一定要小于前面公路的Y坐标,这个时候逆序数就登场啦(๑•ᴗ•๑)
树状数组用来求逆序数,每次计算当前Y与之前的Y的逆序数的个数累加。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 500005
int c[MAXN],no,num[MAXN];
struct Node
{
    int x,y;
} a[MAXN];
bool cmp(Node a,Node b)
{
    if(a.x!=b.x) return a.x<b.x;
    return a.y<b.y;
}
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int v)
{
    while(x<=no)
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
long long getsum(int x)
{
    long long sum=0;
    while(x)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    int T,ca=0;
    scanf("%d",&T);
    while(T--)
    {
        long long ans;
        int n,m,k;
        no=-1;
        scanf("%d%d%d",&n,&m,&k);
        memset(c,0,sizeof(c));
        for(int i=0; i<k; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            no=max(no,a[i].y);
        }
        sort(a,a+k,cmp);//对输入的序列排序
        ans=0;
        for(int i=0; i<k; i++)
        {
            ans+=getsum(no)-getsum(a[i].y);
            update(a[i].y,1);
        }
        printf("Test case %d: %I64d\n",++ca,ans);
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值