HDU 1556-Color the ball(树状数组-区间修改 单点查询)

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15491    Accepted Submission(s): 7731


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
  
  
1 1 1 3 2 1
 

Author
8600
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1542  1394  1698  1255  2795

题目意思很简单,但是数据量不算小,直接暴力会超时,所以考虑用树状数组。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
const int MAXN=100005;
int n;
int c[MAXN];

int lowbit(int x)
{
    return x&(-x);
}
void update(int i,int x)
{
    while(i)
    {
        c[i]+=x;
        i-=lowbit(i);
    }
}

int sum(int i)
{
    int res=0;
    while(i<=n)
    {
        res+=c[i];
        i+=lowbit(i);
    }
    return res;
}
int main()
{
    int a,b;
    while(scanf("%d",&n),n)
    {
        memset(c,0,sizeof(c));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&a,&b);//c[a]~c[b]全部加1
            update(a-1,-1);//c[a]之前的全部减1
            update(b,1);//c[b]之前的全部加1
        }
        for(int i=1; i<n; i++)//输出1-N
            printf("%d ",sum(i));
        printf("%d",sum(n));
        printf("\n");
    }
    return 0;
}

 顺便附一下暴力超时的代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
const int maxn=100005;
int s[maxn];

int main()
{
    int a,b,n;
    while(scanf("%d",&n),n)
    {
        memset(s,0,sizeof(s));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&a,&b);
            for(int j=a; j<=b; ++j)
                ++s[j];
        }
        for(int i=1; i<n; i++)
            printf("%d ",s[i]);
        printf("%d",s[n]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值