专题二 1004

一. 题目编号

1004

Toxophily

Problem Description

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object’s coordinates, please calculate the angle between the arrow and x-axis at Bob’s point. Assume that g=9.8N/m.

Input

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow’s exit speed.
Technical Specification
1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.

Output

For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output “-1”, if there’s no possible answer.
Please use radian as unit.

Sample Input

3
0.222018 23.901887 121.909183
39.096669 110.210922 20.270030
138.355025 2028.716904 25.079551

Sample Output

1.561582
-1
-1

Source

The 4th Baidu Cup final

二. 简单题意

已知发射点坐标为(0,0)和重力加速度g=9.8,给出目标的坐标和初速度,求能够击中目标的最小仰角。

三. 解题思路形成过程

  • 用三分+二分
    首先三分仰角,求出轨迹在x处的纵坐标,若纵坐标最大值小于y,则直接输出-1,三分过后[0,r]上就是单调递增的,直接二分即可

  • 用数学方法解题可以实现0ms通过。
    用公式,根据正交分解坐标系,得出方程的通式。

    x^2*g/(2*v^2)*tan^2(ß) - x*tan(ß) +y + x^2*g/(2*v^2) = 0;
    即:

    • a = g*pow(x,2)/(2*pow(v,2));
    • b = -x;
    • c = y + g*pow(x,2)/(2*pow(v,2));

    根据求根公式求出根。
    注意讨论:
    1. x==0&&y==0时,ß = 0;
    2. x==0&&y>0时,ß=90;
    3. 方程无解时 ß=-1;
    4. 方程的解为负数时,ß=-1;(0<=ß<=90)。

四. 感想

其实这一个题思路并不是很清晰,一开始用的是直接二分,后来查资料发现还有直接用公式这个方法效率高的不行,就改成了现在AC的样子。

五. AC代码

#include <iostream>
#include<iomanip>
#include<cmath>
using namespace std;
int main()
 {
     int t;
     double a,b,c,e,z;
     double x,y,v,g=9.8,l,m1,m2;
    cin>>t;
     while(t--){
         cin>>x>>y>>v;
         if(x==0&&y==0)
         cout<<0<<endl;
         else if(x==0&&y>0)
         cout<<90<<endl;
         else
         {
             a = g*pow(x,2)/(2*pow(v,2));
             b = -x;
             c = y+a;
             l = pow(b,2) - 4*a*c;
             e = 0;
             if(l<0)
            cout<<-1<<endl;
             else
             {
                 m1 = ((-b)+pow(l,1.0/2))/(2*a);
                 m2 = ((-b)-pow(l,1.0/2))/(2*a);
                 if(m1>=0) e = atan(m1);
                 if(m2>=0)
                 {
                     z =  atan(m2);
                     if(z<e)
                        e = z;
                     cout<<fixed<<setprecision(6)<<e<<endl;
                 }
                 if(m1<0&&m2<0)
                   cout<<-1<<endl;
             }
         }
     }
     return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值