poj2533 Longest Ordered Subsequence (最长上升子序列)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 57954 Accepted: 25949

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

打完代码以为万无一失的,结果找了很久的bug,发现是思路有点小问题。

我之前的思路是找前面最接近该元素的比该元素小的元素,进行DP......

给一组数据

4

1 2 0 4

WA了找不到错误的可以试试。

然后,这个是严格意义上的上升序列,所以得元素相等的得排除


以下是AC代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
int main()
{
    int n;
    while(cin >> n)
    {
        int a[1111];
        int dp[1111];
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        a[0] = -1;
        int maxx = -1;
        for(int i = 1; i <= n; i++)
            cin >> a[i];
        for(int i = 1; i <=n; i++)
        {
            int temp = -1;
            for(int i1 = i-1; i1 >= 0; i1--)
            {
                if(a[i] > a[i1])
                {
                    temp = max(dp[i1] + 1,temp);
                }
            }
            dp[i] = temp;
            //int i1 =  i;
            //  while(a[i] <= a[i1 -1])
            //  i1--;

            maxx = max(maxx,dp[i]);
        }
        cout << maxx <<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值