List Leaves(树的层序遍历)(队列)

03-树2 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5


题意:按从下到上(优先),从左到右的方向遍历出所有叶子结点

思路:先找出根结点,加入队列,循环,如果当前结点为叶结点,则输出当前节点,再把当前结点的左右孩子(非空)加入队列中

反思:写错了一个符号,找了半天才找到,关键是这个符号的错误跟测试点的解释一点关系都没有。。。。

附上AC代码:

#include <cstdio>   
#include <iostream> 
#include <algorithm> 
#include <cmath> 
#include <cstdlib> 
#include <cstring> 
#include <vector> 
#include <list> 
#include <map> 
#include <stack> 
#include <queue> 
using namespace std; 
#define ll long long
struct Tree {
	int i;
	char l,r;
};
bool f[30];
bool flag;
Tree T[10];
queue<Tree> t; 
int n;
void set()
{
	for(int i = 0;i < n;i++)
		if(f[i] == 0)
		{
			t.push(T[i]);
			break;
		}
	while(!t.empty())
	{
		Tree x = t.front();
		t.pop();
		if(x.l == '-'&&x.r == '-')
		{
			if(flag)
				cout <<' '<< x.i ;
			else
			{
				cout << x.i;
				flag = 1;
			}
		}
		if(x.l != '-')
			t.push(T[x.l-'0']);
		if(x.r != '-')
			t.push(T[x.r-'0']);
	}
}
int main() 
{
	flag = 0;
	memset(f,0,sizeof(f));
	cin >> n;
	for(int i = 0;i < n;i++)
	{
		cin >> T[i].l >> T[i].r;
		if(T[i].l != '-')
			f[T[i].l-'0'] = 1;
		if(T[i].r != '-')
			f[T[i].r-'0'] = 1;
		T[i].i = i;
	}
	set();
    //cout << "AC" <<endl; 
    return 0; 
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值