数据结构——List Leaves

题目:

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 1010) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1N1. Then NN lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5
题目来源: 程序设计实验辅助教学

题目分析:

通过输入节点数以及每个节点的左儿子和右儿子,从上到下打印出叶节点。
要理解输入的第几行就是代表该节点的值为几。例如样例输入中,第0行的 1 - 代表值为0的节点左孩子的值为1,即指向第1行,右孩子为空,第1行的 - -代表为1的节点的左右孩子都为空。
树模型如下:
程序代码:
#define MaxTree 10
#define ElementType char
#define Tree int
#define Null -1

#include<stdio.h>
#include<stdlib.h>

typedef struct 
{
	ElementType Element;
	Tree Left;
	Tree Right;
}TreeNode;

TreeNode T[MaxTree];
TreeNode Queue[MaxTree];
int front = -1, rear = -1;
void AddQ(TreeNode tn);
TreeNode DeleteQ();
void listLeaves(int root, int n);

int main()
{
	int i, N, Root;
	char cl, cr;

	scanf("%d", &N);
	getchar();
	if (N){
		int check[8];//用来判断根节点的数组
		for (i = 0; i < N; i++)
		{
			check[i] = 0;
		}
		for (i = 0; i < N; i++)
		{
			scanf("%c %c", &cl, &cr);
			getchar();
			T[i].Element = i; // 
			if (cl != '-'){
				T[i].Left = cl - '0';
				check[T[i].Left] = 1;
			}
			else
			{
				T[i].Left = Null;
			}
			if (cr != '-'){
				T[i].Right = cr - '0';
				check[T[i].Right] = 1;
			}
			else
			{
				T[i].Right = Null;
			}
		}
		for (i = 0; i < N; i++)
		{
			if (!check[i]){
				Root = i;
				break;
			}
		}
	}
	listLeaves(Root, N);
	
	return 0;
}

// 插入队列
void AddQ(TreeNode treeNode)
{
	Queue[++rear] = treeNode;
}

// 从队列中删除元素
TreeNode DeleteQ()
{
	return Queue[++front];
}

void listLeaves(int root, int n)
{
	int leaves[MaxTree];
	int k = 0;
	AddQ(T[root]);
	for (int i = 0; i < n; i++)
	{
		TreeNode tn	= DeleteQ();
		if (tn.Left == Null && tn.Right == Null)
			leaves[k++] = tn.Element;
		if (tn.Left != Null)
			AddQ(T[tn.Left]);
		if (tn.Right != Null)
			AddQ(T[tn.Right]);
	}
	for (int i = 0; i < k - 1; i++)
		printf("%d ", leaves[i]);
	printf("%d\n",leaves[k-1]);
}

参考代码:点击打开链接


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值