问题 A: Assignment Algorithm

问题 A: Assignment Algorithm

时间限制: 1 Sec  内存限制: 512 MB

题目描述

A low-budget airline is designing a sophisticated algorithm that will assign more desirable seats to passengers who buy tickets earlier. Their airplane has r rows of seats, where r is an even integer. There are also 3 exit rows in the airplane; those rows do not contain any seats but only provide access to the emergency exits. One exit row is in the very front of the airplane (before the first row of seats), one in the very back (behind the last row of seats) and one right in the middle. The rows are numbered with integers 1 through r + 3 with row numbers increasing from the front to the back of the airplane. Rows numbered 1, r/2 + 2 and r + 3 are exit rows while all the other rows are seat rows.
The seating configuration is “3–3–3” — each seat row contains three groups of three seats with the passenger aisles between the groups. Seats in the same row are denoted with consecutive letters left to right corresponding to the pattern “ABC.DEF.GHI”.
When a passenger purchases a ticket, she is assigned a seat according to the following rules:
1. If there is an empty seat in a row directly after an exit row, all other rows are ignored in the following step (but they are not ignored when balancing the airplane in the last step).
2. first, we select a seat row with the largest number of empty seats. If there are multiple such rows,we select the one closest to an exit row (distance between rows a and b is simply |a − b|). If there are still multiple such rows, we select the one with the lowest number.
3. Now, we consider empty seats in the selected row and select one with the highest priority. Seat priorities, from highest to lowest are as follows:
(a) Aisle seats in the middle group (D or F).
(b) Aisle seats in the first and third group (C or G).
(c) Window seats (A or I).
(d) Middle seat in the middle group (E).
(e) Other middle seats (B or H).
If there are two empty seats with the same highest priority, we consider the balance of the entire airplane. The airplane’s left side contains all seats with letters A, B, C or D, while the right side contains all seats with letters F, G, H or I. We select an empty seat in the side with more empty seats. If both sides have the same number of empty seats, we select the seat in the left side of the airplane.
Some of the airplane’s seats are already reserved (possibly using a completely different procedure from the one described above). Determine the seats assigned to the next n passengers purchasing a ticket.

输入

The first line contains two integers r and n (2 ≤ r ≤ 50, 1 ≤ n ≤ 26) — the number of seat rows in the airplane (always an even integer) and the number of new passengers purchasing tickets. The following r + 3 lines contain the current layout of the airplane. The j-th line contains exactly 11 characters — the layout of the row j of the airplane. Exit rows and aisles are denoted with the “.” characters. The “#” character denotes a reserved seat, while the “-” character denotes a seat that is currently empty. You may assume there will be at least n empty seats in the airplane.

输出

Output r + 3 lines containing the final layout of the irplane. The layout should be exactly the same as in input with the following exception: the seat assigned to the j-th passenger purchasing a ticket should be denoted with the j-th lowercase letter of the English alphabet.

样例输入

2 17

...........

---.#--.---

...........

---.---.---

...........

样例输出

...........

hnd.#lb.fpj

...........

kqg.cma.eoi

...........





题目大意:

题意很恶心。。。



分析:

模拟就ok







AC代码:

#include<bits/stdc++.h>
#define lowbit(x) (x&-x)
#define gcd(a,b) __gcd(a,b)
#define mset(a,x) memset(a,x,sizeof(a))
#define FIN     freopen("input","r",stdin)
#define FOUT    freopen("output","w",stdout)
const int INF=0x3f3f3f3f;
const double PI=acos(-1.0);
const double eps=1e-6;
const int MAX=1e5+10;
const int mod=1e9+7;
typedef long long ll;
using namespace std;
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
inline ll qpow(ll a,ll b){ll r=1,t=a; while(b){if(b&1)r=(r*t)%mod;b>>=1;t=(t*t)%mod;}return r;}
inline ll inv1(ll b){return qpow(b,mod-2);}
inline ll inv2(ll b){return b==1?1:(mod-mod/b)*inv2(mod%b)%mod;}
inline ll exgcd(ll a,ll b,ll &x,ll &y){if(!b){x=1;y=0;return a;}ll r=exgcd(b,a%b,y,x);y-=(a/b)*x;return r;}
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int r,n;
char Map[105][105];
int cal(){
    int suml=0,sumr=0;
    for (int j=1;j<=r+3;j++){
        for (int k=0;k<5;k++){
            if(Map[j][k]=='-') suml++;
        }
    }
    for (int j=1;j<=r+3;j++){
        for (int k=6;k<11;k++){
            if(Map[j][k]=='-') sumr++;
        }
    }
    if (suml>=sumr) return 0;
    return 1;
}
void work(int Index,int i){
    int temp=cal();
    if(Map[Index][4]=='-'&&Map[Index][6]=='-'){
        if(temp==0) Map[Index][4]=i+'a';
        else Map[Index][6]=i+'a';
    }
    else if(Map[Index][4]=='-'||Map[Index][6]=='-'){
        if(Map[Index][4]=='-') Map[Index][4]=i+'a';
        else Map[Index][6]=i+'a';
    }
 
    else if(Map[Index][2]=='-'&&Map[Index][8]=='-'){
        if(temp==0) Map[Index][2]=i+'a';
        else Map[Index][8]=i+'a';
    }
    else if(Map[Index][2]=='-'||Map[Index][8]=='-'){
        if(Map[Index][2]=='-') Map[Index][2]=i+'a';
        else Map[Index][8]=i+'a';
    }
 
    else if(Map[Index][0]=='-'&&Map[Index][10]=='-'){
        if(temp==0) Map[Index][0]=i+'a';
        else Map[Index][10]=i+'a';
    }
    else if(Map[Index][0]=='-'||Map[Index][10]=='-'){
        if(Map[Index][0]=='-') Map[Index][0]=i+'a';
        else Map[Index][10]=i+'a';
    }
    else if(Map[Index][5]=='-') {Map[Index][5]=i+'a';}
 
    else if(Map[Index][1]=='-'&&Map[Index][9]=='-'){
        if(temp==0) Map[Index][1]=i+'a';
        else Map[Index][9]=i+'a';
    }
    else if(Map[Index][1]=='-'||Map[Index][9]=='-'){
        if(Map[Index][1]=='-') Map[Index][1]=i+'a';
        else Map[Index][9]=i+'a';
    }
}
int main (){
    scanf ("%d%d",&r,&n);
 
    for (int i=1;i<=r+3;i++) scanf ("%s",Map[i]);
 
    for (int i=0;i<n;i++){
        int sum1=0,sum2=0;
 
        for (int j=0;j<11;j++){
            if(Map[2][j]=='-') sum1++;
            if(Map[r/2+3][j]=='-') sum2++;
        }
 
        if(!sum1&&!sum2){
            int Index;
            int maxn=0;
            for (int j=1;j<=r+3;j++){
                int sum=0;
                for (int k=0;k<11;k++){
                    if(Map[j][k]=='-') sum++;
                }
                maxn=max(maxn,sum);
            }
            int minn=INF;
             for (int j=1;j<=r+3;j++){
                int sum=0;
                for (int k=0;k<11;k++){
                    if(Map[j][k]=='-') sum++;
                }
                if(sum==maxn){
                    int mindis=min(abs(j-(r+3)),min(abs(j-1),abs(j-(r/2+2))));
                    if(minn>mindis){
                        Index=j;
                        minn=mindis;
                    }
                }
            }
            work(Index,i);
        }
        else{
            int Index;
            if(sum1>=sum2) Index=2;
            else if(sum1<sum2) Index=r/2+3;
 
            work(Index,i);
        }
    }
    for (int i=1;i<=r+3;i++) printf ("%s\n",Map[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值