A Bug's Life(并查集)

 

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

并查集问题,输入互相交配的昆虫,找是否存在同性恋的昆虫,在这里会将昆虫看作节点。

将两种性别的昆虫分别放入两个集合,若发现输入的昆虫在同一个集合里,则它们是同性。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
#include <cmath>
using namespace std;
int ch[2222];                //记录昆虫的对象
int F[2222];
int rank1[2222];
int find1(int n)             //找根节点
{
    int root=n;
    while(root!=F[root])
        root=F[root];
    return root;
}
void union1(int x,int y)    //将两个节点放在同一个集合里
{
    int root1=find1(x);
    int root2=find1(y);
    if(rank1[root1]>rank1[root2])
        F[root2]=root1;
    else
    {
        F[root1]=F[root2];
        if(rank1[root1]==rank1[root2])
            rank1[root1]++;
    }
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    for(int j=1; j<=t; j++)
    {
        int k=0;
        memset(ch,0,sizeof(ch));
        memset(rank1,0,sizeof(rank1));
        scanf("%d%d",&n,&m);
        for(int i=0; i<=n; i++)            //初始化
            F[i]=i;
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(find1(a)==find1(b))         //如果根节点相同,则两昆虫在同一集合里,为同性
                k=1;
            else
            {
                if(ch[a]==0&&ch[b]==0)     //a,b在此前都没有对象
                {
                    ch[a]=b;               //a的对象赋值为b
                    ch[b]=a;               //b的对象赋值为a
                }
                else if(ch[a]==0)          //a此前没有对象,b有
                {
                    ch[a]=b;               //同上
                    union1(a,ch[b]);       //将a放在b的异性集合中
                }
                else if(ch[b]==0)          //b此前没对象,a有
                {
                    ch[b]=a;
                    union1(b,ch[a]);       //将b放在a的异性集合中
                }
                else                       //a,b都有对象
                {
                    union1(b,ch[a]);       //b放在a的异性集合中
                    union1(a,ch[b]);       //a放在b的异性集合中
                }
            }
        }
        printf("Scenario #%d:\n",j);
        if(k==0)
            printf("No suspicious bugs found!\n");
        else
            printf("Suspicious bugs found!\n");
        cout << endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值