Milking Cows 挤牛奶(贪心) ( 错了n发之后的总结 )

Description

三个农民每天清晨5点起床,然后去牛棚给3头牛挤奶。第一个农民在300时刻(从5点开始计时,秒为单位)给他的牛挤奶,一直到1000时刻。第二个农民在700时刻开始,在 1200时刻结束。第三个农民在1500时刻开始2100时刻结束。期间最长的至少有一个农民在挤奶的连续时间为900秒(从300时刻到1200时刻),而最长的无人挤奶的连续时间(从挤奶开始一直到挤奶结束)为300时刻(从1200时刻到1500时刻)。 你的任务是编一个程序,读入一个有N个农民(1 <= N <= 5000)挤N头牛的工作时间列表,计算以下两点(均以秒为单位): 最长至少有一人在挤奶的时间段。 最长的无人挤奶的时间段。(从有人挤奶开始算起)

Input

Line 1: 一个整数N。 Lines 2..N+1: 每行两个小于1000000的非负整数,表示一个农民的开始时刻与结束时刻。

Output

一行,两个整数,即题目所要求的两个答案。

Sample Input

3
300 1000
700 1200
1500 2100

Sample Output

900 300

题解:

 我的思路就是用结构体把每个人开始和结束的时刻都存起来,刚开始我是按照开始的时间从小到大排序,若开始时间一致,则按照结束时间从小到大排序,其实只需要按照开始的时间从小到大排序就好,将有人的时间段存在x [ ] 数组中,然后找出最大值

WA的n发都是因为没考虑全情况,只把后一个跟前一个做了比较,没考虑到这种情况:

后来对这种情况又没有处理好。。。

代码如下:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#define MAXN 0x3f3f3f3f
using namespace std;
typedef long long LL;
struct node
{
    int s,e;
}a[5555];
int cmp(node c,node d)
{
    return c.s < d.s;
}
int main()
{
    int n;
    cin >> n;
    for(int i=0;i<n;i++)
        scanf("%d%d",&a[i].s,&a[i].e);
    sort(a,a+n,cmp);
    int x[5555],y=0,p=0,max1=a[0].e;
    memset(x,0,sizeof(x));
    x[0]=a[0].e-a[0].s;
    for(int i=1;i<n;i++)
    {
        if(a[i].s<=max1&&a[i].e>=max1)
        {
            x[p]+=a[i].e-max1;
            max1=a[i].e;
        }
        else if(a[i].s>max1)
        {
            y=max(y,a[i].s-max1);
            p++;
            max1=a[i].e;
            x[p]=max1-a[i].s;
        }
    }
    int MAX=0;
    for(int i=0;i<=p;i++)
    {
        if(MAX<x[i])
            MAX=x[i];
    }
    printf("%d %d\n",MAX,y);
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
02-12
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值