zcum1075: 求n!

1075: 求n!

Description
输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
读入 1 个正整数 n (n<=22),计算并输出 n! 。

Input
见sample

Output
见sample

Sample Input
3
1
10
5
Sample Output
1
3628800
120

代码

#include<stdio.h>
double fact(int n);
int main()
{
	int i,r,n;
	scanf("%d",&r);
	if(r>0&&r<10){
		for(i=1;i<=r;i++){
			scanf("%d",&n);
			if(n<=22)
			printf("%.0f\n",fact(n));	
		}
	}
	return 0;
}
double fact(int n)
{
	double result,x;
	result=1;
	for(x=1;x<=n;x++){
		result=result*x;		
	}
	return result;
}
在这里插入代码片
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值