Time Limit: 1000MS Memory limit: 65536K
题目描述
请用链表完成下面题目要求。
xiaobai 很喜欢音乐,几年来一直在收集好听的专辑。他有个习惯,每次在听完一首音乐后会给这首音乐打分,而且会隔一段时间给打好分的音乐排一个名次。今天 xiaobai 打开自己的音乐文件夹,发现有很多不同时期打过分的排好序的子音乐文件夹,他想把这些音乐放到一块,组成一个分数有序的序列。由于音乐文件很多,而文件里音乐的数目也是不确定的,怎么帮帮 xiaobai 完成这件工作呢?
输入
输入数据第一行为一个整数n(n<1000),代表文件夹的数量。接下来是n个文件夹的信息,每个文件夹信息的第一行是一个数字m,代表这个文件夹里有m首歌,后面m行每行一个歌曲名、分数,之间用空格分开。
输出
输出一行,为所有音乐组成的一个序列,音乐只输出名字。
如果音乐分数相同则按照音乐名字典序进行排序。
示例输入
34aaa 60aab 50aac 40aad 302kkk 60kkd 593qow 70qwe 60qqw 20
示例输出
qow aaa kkk qwe kkd aab aac aad qqw
提示#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int mark;
char name[30];
struct node *next;
};
struct node *creat(int n)
{
struct node *head,*tail,*p;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%s %d",p->name,&p->mark);
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}
struct node *merge(struct node *head1,struct node *head2)
{
struct node *p1,*p2,*tail;
p1=head1->next;
p2=head2->next;
tail=head1;
free(head2);
while(p1&&p2)
{
if(p1->mark>p2->mark)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else if(p1->mark<p2->mark)
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
else
{
if(strcmp(p1->name,p2->name)<0)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
}
}
if(p1)
tail->next=p1;
else tail->next=p2;
return head1;
}
int main()
{
int m,n,i;
struct node *head1,*head2;
scanf("%d %d",&n,&m);
head1=creat(m);
for(i=2;i<=n;i++)
{
scanf("%d",&m);
head2=creat(m);
head1=merge(head1,head2);
}
while(head1->next!=NULL)
{
if(head1->next->next!=NULL)
printf("%s ",head1->next->name);
else printf("%s\n",head1->next->name);
head1=head1->next;
}
free(head1);
return 0;
}
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int mark;
char name[30];
struct node *next;
};
struct node *creat(int n)
{
struct node *head,*tail,*p;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%s %d",p->name,&p->mark);
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}
struct node *merge(struct node *head1,struct node *head2)
{
struct node *p1,*p2,*tail;
p1=head1->next;
p2=head2->next;
tail=head1;
free(head2);
while(p1&&p2)
{
if(p1->mark>p2->mark)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else if(p1->mark<p2->mark)
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
else
{
if(strcmp(p1->name,p2->name)<0)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
}
}
if(p1)
tail->next=p1;
else tail->next=p2;
return head1;
}
int main()
{
int m,n,i;
struct node *head1,*head2;
scanf("%d %d",&n,&m);
head1=creat(m);
for(i=2;i<=n;i++)
{
scanf("%d",&m);
head2=creat(m);
head1=merge(head1,head2);
}
while(head1->next!=NULL)
{
if(head1->next->next!=NULL)
printf("%s ",head1->next->name);
else printf("%s\n",head1->next->name);
head1=head1->next;
}
free(head1);
return 0;
}