数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu

示例输出

dgebfca
abcdefg
linux
xnuli

提示

 

来源

ma6174
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
    int data;
    struct node *l,*r;
};
struct node *creat(int n,char *str1,char *str2)
{
    struct node *root;
    char *p;
    if(n==0)
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    root->data=str1[0];
    for(p=str2;p!='\0';p++)
    {
        if(*p==str1[0])
            break;
    }
    int t=p-str2;
    root->l=creat(t,str1+1,str2);
    root->r=creat(n-t-1,str1+t+1,p+1);
    return root;
};
void houxu(struct node *root)
{
    if(root)
    {
        houxu(root->l);
        houxu(root->r);
        printf("%c",root->data);
    }
}
void bianli(struct node *root)
{
    int c=0;
    int r1=1;
    struct node *q[60];
    q[0]=root;
    while(c<r1)
    {
        if(q[c])
        {
            printf("%c",q[c]->data);
            q[r1++]=q[c]->l;
            q[r1++]=q[c]->r;
        }
        c++;
    }
}
int main()
{
    int n;
    char str1[60],str2[60];
    struct node *root;
    root=(struct node *)malloc(sizeof(struct node));
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        scanf("%s %s",str1,str2);
        int n=strlen(str1);
        root=creat(n,str1,str2);
        houxu(root);
        printf("\n");
        bianli(root);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值