Game HDU - 3389 (Nim)

Bob and Alice are playing a new game. There are n boxes which have been numbered from 1 to n. Each box is either empty or contains several cards. Bob and Alice move the cards in turn. In each turn the corresponding player should choose a non-empty box A and choose another box B that B<A && (A+B)%2=1 && (A+B)%3=0. Then, take an arbitrary number (but not zero) of cards from box A to box B. The last one who can do a legal move wins. Alice is the first player. Please predict who will win the game. 

Input

The first line contains an integer T (T<=100) indicating the number of test cases. The first line of each test case contains an integer n (1<=n<=10000). The second line has n integers which will not be bigger than 100. The i-th integer indicates the number of cards in the i-th box.

Output

For each test case, print the case number and the winner's name in a single line. Follow the format of the sample output.

Sample Input

2
2
1 2
7
1 3 3 2 2 1 2

Sample Output

Case 1: Alice
Case 2: Bob

 题意:有n堆石子,下标1~n,两个人玩游戏,轮流操作,每轮玩家可以任意选择两个堆石子下标为a, b,并且满足b < a;a > 0;(a + b) % 2 = 1;(a + b) % 3 = 1。玩家可以将a中任意石头(大于0)拿放到b中,Alice先手,不能操作者失败。

题解:当不能操作时,所以石头必当移动到1,3,4中,当列出表后就会知道,满足:

(i % 3 == 1 || i & 3 == 2) && (i / 3) % 2 == 0  的堆合并到1中;

(i % 3 == 1 || i & 3 == 2) && (i / 3) % 2 == 1  的堆合并到4中;

i % 3 == 0  的堆合并到3中。

我们假设现在只有一颗石头,当这颗石头需要移动奇数才能到达终点时,则先手必胜。

现在存在很多石头就是nim博弈,求个异或和就行了。

所以现在只需要计算每颗石头移动到终点需要步数的奇偶性就行了。

简化后的代码如下:

//#include<bits/stdc++.h>
//#include<unordered_map>
//#include<unordered_set>
#include<iostream>
#include<sstream>
#include<iterator>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<bitset>
#include<climits>
#include<queue>
#include<iomanip>
#include<cmath>
#include<stack>
#include<map>
#include<ctime>
#include<new>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a, b) memset(a,b,sizeof(a))
#define lson l, mid, node<<1
#define rson mid + 1, r, node<<1|1
const LL INF  =  0x3f3f3f3f3f3f;
const int O    =  1e6;
const int mod  =  1e9+7;
const int maxn =  2e3 +5;
const double PI  =  acos(-1.0);
const double E   =  2.718281828459;
const double eps = 1e-8;

int main(){
    int T, l = 0; cin >> T;
    while( T --) {
        int n; cin >> n;
        int ans = 0;
        for(int i=1; i<=n; i++ ) {
            int x; cin >> x;
            if(i % 3 == 2) ans ^= x;
            if(i % 3 == 0 && !(i % 2)) ans ^= x;
        }
        if(ans) printf("Case %d: Alice\n", ++l);
        else printf("Case %d: Bob\n", ++l);
}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值