hdu3389 Game

67 篇文章 1 订阅

Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 255 Accepted Submission(s): 174


Problem Description
Bob and Alice are playing a new game. There are n boxes which have been numbered from 1 to n. Each box is either empty or contains several cards. Bob and Alice move the cards in turn. In each turn the corresponding player should choose a non-empty box A and choose another box B that B<A && (A+B)%2=1 && (A+B)%3=0. Then, take an arbitrary number (but not zero) of cards from box A to box B. The last one who can do a legal move wins. Alice is the first player. Please predict who will win the game.

Input
The first line contains an integer T (T<=100) indicating the number of test cases. The first line of each test case contains an integer n (1<=n<=10000). The second line has n integers which will not be bigger than 100. The i-th integer indicates the number of cards in the i-th box.

Output
For each test case, print the case number and the winner's name in a single line. Follow the format of the sample output.

Sample Input
  
  
2 2 1 2 7 1 3 3 2 2 1 2

Sample Output
  
  
Case 1: Alice Case 2: Bob
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
    int tcase,n,i,pri,tt=1,ans;
    scanf("%d",&tcase);
    while(tcase--){
        scanf("%d",&n);
        for(ans=0,i=1;i<=n;i++){
            scanf("%d",&pri);
            if(i%3==2||(i%6==0))
            ans^=pri;
        }
        if(ans)printf("Case %d: Alice\n",tt++);
        else printf("Case %d: Bob\n",tt++);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值