Dividing (多重背包-二进制优化)

     Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.

    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.


Input
    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

    The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.


Output
    For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

    Output a blank line after each test case.


Sample Input

    1 0 1 2 0 0
    1 0 0 0 1 1
    0 0 0 0 0 0

Sample Output

    Collection #1:
    Can't be divided.

    Collection #2:

    Can be divided.


题意:输入价值为1 2 3 4 5 6的物品个数,任意组合这些物品,判断是否能组合为总价值的一般


二进制优化原理: 最终的答案意义为,确定每个物品的选取的数量,
        就把每个物品的数量N拆分为由小到大的2^k的和。由2^k的性质,小
        于N的每一个数都可由,选取其中一定个数2^k相加来表示,所以就可
        把 2^k * v 看做另一个物品放入数组中,再有01背包求解。

        例如 价值为2的物品有17个,就拆分为价值为 
        2*1 ,2*2,2*4,2*8,2*(17-1-2-4-8)的五个物品,我们用A,B,C,D,E来表示。
        若价值为2的物品我们取0个,则ABCDE都不取;若我们要取7个,则就取物品ABC三个;
        若我们要取16个,就取物品BCDE四个,依次类推。

        为何的到了优化?我们想想若一个物品有1e10个,若全部放入数组中,
        就是1e10个物品,若以2^k拆分,就会不超过30个物品,具体多少自己
        去算。

#include<bits/stdc++.h>
#include<iostream>
#include<cstring>
using namespace std;
#define MT(a,b) memset(a,b,sizeof(a))
#define ll long long
const int maxn = 2e5+5;
const int N = 1e5;

int main()
{
    int l=0;
    while(!0)
    {
        int a[7];
        int sum=0;
        for(int i=1;i<7;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i]*i;
        }
        if(!sum) break;
        cout<<"Collection #"<<++l<<":"<<endl;
        if(sum&1)
        {
            cout<<"Can't be divided."<<endl;
            cout<<endl;
            continue;
        }


        /*

        
        下面几行代码就是二进制优化

        */

        int cnt = 0;
        int v[maxn];MT(v,0);
        for(int i=1;i<7;i++)
        {
            for(int j=1;j<=a[i];j<<=1)
            {
                v[cnt++]=j*i;
                a[i]-=j;
            }
            if(a[i]>0)
                v[cnt++]=a[i]*i;
        }


        /*01背包*/

        int f[maxn];MT(f,0);
        for(int i=0;i<cnt;i++)
        {
            for(int j=sum/2;j>=v[i];j--)
            {
                f[j]=max(f[j],f[j-v[i]]+v[i]);
            }
        }


        if(f[sum/2]==sum/2)cout<<"Can be divided."<<endl;
        else cout<<"Can't be divided."<<endl;
        cout<<endl;
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值