Free DIY Tour(dp)

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?


Input The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input
2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4
Sample Output
CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

题意:给出一个带权值的有向图,求起点到“终点“的最大价值,并输出路径

#include<bits/stdc++.h>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define MT(a,b) memset(a,b,sizeof(a))
#define ll long long
const int maxn = 2e5+5;
const int ONF = -0x3f3f3f3f;
const int INF = 0x3f3f3f3f;
const int N = 2e2+5;

int main()
{
    int n;cin>>n;
    int l=0;
    while(n--)
    {
        int v[N];     MT(v,0);
        int mp[N][N]; MT(mp,0);//邻接矩阵记录节点
        int k;cin>>k;
        for(int i=1;i<=k;i++) scanf("%d",&v[i]);
        int t;cin>>t;
        for(int i=0;i<t;i++)
        {
            int l,r; scanf("%d%d",&l,&r);
            mp[l][r]=1;
        }
        int dp[N];   MT(dp,0);//dp[i]表示起点到i的最大价值
        int way[N];  MT(way,0);//way[i]表示以最大价值指向i点的点
        
        for(int i=1;i<=k+1;i++)
        {
            for(int j=1;j<i;j++)//遍历找每点,找到能到达i点的点
            {
                if(mp[j][i]&&dp[j]+v[i]>dp[i])//如果j点的dp加上i点的价值比dp[i]大,就赋值dp[i]
                {
                    dp[i]=dp[j]+v[i];
                    way[i]=j;//记录j
                }
            }
        }
        
        cout<<"CASE "<<++l<<"#"<<endl<<"points : "<<dp[k+1]<<endl<<"circuit : ";
       int p=k+1;
       stack<int >st;//因为way[i]记录的是上一个点,所以就从最后一个点依次压住栈中,方向输出
       while(way[p])
       {
           st.push(way[p]);
           p=way[p];
       }
       while(!st.empty())
       {
           cout<<st.top()<<"->";
           st.pop();
       }
       cout<<"1"<<endl;
       if(n)cout<<endl;
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值